Se ha producido un error al recortar la imagen y cómo solucionarlo en WordPress

El usar php7 en una instalación nueva, ya sea en servidor local -tipo XAMPP- o dedicado puede generar varios mensajes de error en nuestra instalación de WordPress, uno de ellos es:

Se ha producido un error al recortar la imagen.

Este mensaje se puede solucinar instalando la librería php7-gd, para ello habrá que conectarse al servidor vía telnet y ejecutar la siguiente línea de comando:

sudo apt-get install php7.0-gd

 

Si tenemos la versión 7.1:

sudo apt-get install php7.1-gd

Si no sabemos qué versión tenemos instalalda podemos crear en el raiz un fichero info.php que tenga el siguiente contenido:

<?php
phpinfo();
?>

Para luego ejecutarlo desde la url de nuestra web, que será del tipo: http://nuestraweb.com/info.php